Not working in openCPN.

 

To comment on questions or provide answers, please login first.
Register | Login

 

Questions and AnswersCategory: Moitessier HATNot working in openCPN.
David asked 2 years ago

im not getting temp or pressure in my openCPN in dashboard. I can see the pressure in I2C page in openploter. All so what cone tor is used on the AIS?

Andy Kopac replied 2 years ago

My board data is visible using SignalK web pages, however I was only able to see all the info once when I first set it up on the dashboard in OpenCPN. I can still get my gps location to show up in OpenCPN. Support is working with me though. I have faith. This board is so new I figured it will take a little bit to get it all to work. It is Really Cool though. Everything I expected and more.

Andy Kopac replied 2 years ago

Try these in terminal for testing:
1. i2cdetect -y 1
2. moitessier/app/sensors/check_functionality -i /dev/i2c-1 -c 5

1 Answers
Thomas Staff answered 2 years ago

First ensure, that you have the latest OpenPlotter software installed.
Start OpenPlotter and enable the I2C sensor as described here: https://docs.sailoog.com/openplotter-v1-x-x/i2c
Then open SignalK: Raspbian menu bar –> OpenPlotter –> SignalK
This will open a web browser and the web application. Login at the right corner. User and password are already filled in the required fields.
Activate the SignalK to NMEA converter and enable the proper NMEA XDR sentences as described at https://docs.sailoog.com/openplotter-v1-x-x/tools/moitessier-hat#configuring-pressure-reception
In the dashboard of OpenCPN enable the instruments “barometric pressure” and “air temp.”

 

To comment on questions or provide answers, please login first.
Register | Login