Headless

 

To comment on questions or provide answers, please login first.
Register | Login

 

Stig Yndgaard asked 1 month ago

My RasPi 4B with MoitessierHat2 start up openplotter and support openVNC for acces with android tablet via IP 10.10.10.1  supported from the RasPi as long as the RasPi is also connected with a HDMI cable to another LCD screen. If I disconnect the HDMI cable and reboot then the tablet display om the tablet that the screen cant be displayed. How do I tell the RasPi to display the expected screen content to my android tablet, not expecting the hdmi cable to be connected? I think the RasPi need some information to run headless ? How do I get that done? I use the “openplotter with moitessier hat” image on the SD card. 

1 Answers
Thomas Staff answered 1 month ago

Hi!

You need to edit your boot configuration.
sudo nano /boot/config.txt

Comment the following line, so it looks as follows:
#dtoverlay=vc4-fkms-v3d

In section [all], this should be at the end of the file, there must be following configuration:
[all]
hdmi_force_hotplug=1
hdmi_group=2
#hdmi_mode=82
framebuffer_width=1900
framebuffer_height=1000

Change framebuffer_width and framebuffer_height to fit your tablet resolution.

Regards,
Thomas

Stig Yndgaard replied 1 month ago

Hi Thomas it works – thank you very much. Suggest that an image fore openplotter with MoitessierHat for headless setup become an option

Thomas Staff replied 1 month ago

Thanks for the feedback!

Regards,
Thomas

 

To comment on questions or provide answers, please login first.
Register | Login