GPS/AIS not working

 

To comment on questions or provide answers, please login first.
Register | Login

 

nicola.lunetti asked 1 year ago

Good morning,
i installed hat2 on pi4 with openplotter version 2 noobs. Everything works properly (gyroscope, pressure, temperature). It does not work gps and ais. I’m also outdoors. The green leds are on steady. No red led. Firmware and drives all updated.
On the forums I find no help.

3 Answers
Thomas Staff answered 1 year ago

Hello Nicola,
do you use the internal GPS antenna or have you connected an external antenna?
Do you have ships equipped with AIS next to your location?
Can you send me a picture of your setup?
Please execute the following command in a terminal and provide the output:
~/moitessier/app/moitessier_ctrl/moitessier_ctrl_$(uname -r) /dev/moitessier.ctrl 1
Regards,
Thomas

nicola.lunetti replied 1 year ago

1 external antenna
2 no ships

pi@openplotter:~ $ ~/moitessier/app/moitessier_ctrl/moitessier_ctrl_$(uname -r) /dev/moitessier.ctrl 1
opening device /dev/moitessier.ctrl
size – 172
mode – A
hardware ID – P770010
hardware version – E05
boot version –
app version – 1.3.0
functionality – 0xffffffff
system errors – 0x00000000
serial – 2d3630304752430700150015
receiver 1
channel frequency 1 [Hz]: 161975000
channel frequency 2 [Hz]: 162025000
tcxo frequency [Hz]: 13000000
meta data mask: 0x00
afc range [Hz]: 1000
default afc range [Hz]: 1000
rng: 0x08 0x08
receiver 2
channel frequency 1 [Hz]: 161975000
channel frequency 2 [Hz]: 162025000
tcxo frequency [Hz]: 13000000
meta data mask: 0x00
afc range [Hz]: 1000
default afc range [Hz]: 1000
rng: 0x08 0x08
simulator
enabled: 0
interval: 1000
mmsi: 807977831 807977832
misc
write protection ID EEPROM: 1
write button pressed: 0

Thomas Staff replied 1 year ago

Is this an external GPS or AIS antenna? Try to use the internal GPS antenna.
Does your GPS antenna have clear view to sky?
Is there other radio equipment next to your HAT? Especially equipment with high output power.
How long was your board powered on before you give up your testing?

If no ships are next to you, you won’t receive any AIS data.

Execute the following command an provide a few lines of the output:
cat /dev/moitessier.spi

nicola.lunetti replied 1 year ago

pi@openplotter:~ $ cat /dev/moitessier.spi
$GPRMC,001828.868,V,,,,,0.00,0.00,060180,,,N,V*3D
$GPVTG,0.00,T,,M,0.00,N,0.00,K,N*32
$GPGGA,001828.868,,,,,0,0,,,M,,M,,*4D
$GPGSA,A,1,,,,,,,,,,,,,,,,1*03
$GPGSA,A,1,,,,,,,,,,,,,,,,2*00
$GPGSV,1,1,00,0*65
$GLGSV,1,1,00,1*78
$GPGLL,,,,,001828.868,V,N*7F
$GPTXT,01,01,02,ANTSTATUS=OPEN*2B
$GPRMC,001829.868,V,,,,,0.00,0.00,060180,,,N,V*3C
$GPVTG,0.00,T,,M,0.00,N,0.00,K,N*32
$GPGGA,001829.868,,,,,0,0,,,M,,M,,*4C
$GPGSA,A,1,,,,,,,,,,,,,,,,1*03
$GPGSA,A,1,,,,,,,,,,,,,,,,2*00
$GPGSV,1,1,00,0*65
$GLGSV,1,1,00,1*78
$GPGLL,,,,,001829.868,V,N*7E
$GPTXT,01,01,02,ANTSTATUS=OPEN*2B
$GPRMC,001830.868,V,,,,,0.00,0.00,060180,,,N,V*34
$GPVTG,0.00,T,,M,0.00,N,0.00,K,N*32
$GPGGA,001830.868,,,,,0,0,,,M,,M,,*44
$GPGSA,A,1,,,,,,,,,,,,,,,,1*03
$GPGSA,A,1,,,,,,,,,,,,,,,,2*00
$GPGSV,1,1,00,0*65
$GLGSV,1,1,00,1*78
$GPGLL,,,,,001830.868,V,N*76
$GPTXT,01,01,02,ANTSTATUS=OPEN*2B
$GPRMC,001831.868,V,,,,,0.00,0.00,060180,,,N,V*35
$GPVTG,0.00,T,,M,0.00,N,0.00,K,N*32
$GPGGA,001831.868,,,,,0,0,,,M,,M,,*45
$GPGSA,A,1,,,,,,,,,,,,,,,,1*03
$GPGSA,A,1,,,,,,,,,,,,,,,,2*00
$GPGSV,1,1,00,0*65
$GLGSV,1,1,00,1*78
$GPGLL,,,,,001831.868,V,N*77
$GPTXT,01,01,02,ANTSTATUS=OPEN*2B

Thomas Staff replied 1 year ago

I need more input from you. You need to answer my questions from the previous comments, otherwise it will be difficult to find a solution. I checked your serial number and I’ve tested the board personally before we shipped it to Sailoog. So it is for sure that GPS was okay.

nicola.lunetti replied 1 year ago

I solved the problem. Detached external GPS antenna and switched to the internal one. all right. Thanks a lot …. you are fantastic.

Rob Comerford answered 5 months ago

I have the same problem, I tried without ext antennae and with currently it’s connected and outside my window. My system looks like this:
pi@raspberrypi:~ $ ~/moitessier/app/moitessier_ctrl/moitessier_ctrl_$(uname -r) /dev/moitessier.ctrl 1
opening device /dev/moitessier.ctrl
size – 204
mode – A
hardware ID – P770010
hardware version – E05
boot version –
app version – 1.6.0
gnss version – L86NR02A02S
functionality – 0xffffffff
system errors – 0x00000000
serial – 2d38323252524306001a000d
receiver 1
channel frequency 1 [Hz]: 161975000
channel frequency 2 [Hz]: 162025000
tcxo frequency [Hz]: 13000000
meta data mask: 0x00
afc range [Hz]: 1000
default afc range [Hz]: 1000
rng: 0x08 0x08
receiver 2
channel frequency 1 [Hz]: 161975000
channel frequency 2 [Hz]: 162025000
tcxo frequency [Hz]: 13000000
meta data mask: 0x00
afc range [Hz]: 1000
default afc range [Hz]: 1000
rng: 0x09 0x09
simulator
enabled: 0
interval: 1000
mmsi: 807977831 807977832
misc
write protection ID EEPROM: 1
write button pressed: 0
gnss satellite systems: 15
pi@raspberrypi:~ $

Rob Comerford replied 5 months ago

Fixed 2 days to find the solution and less than a minute to fix. At least I learnt something from the ordeal 🙂
problem #hdmi_safe=1
solution hdmi_safe=1
Now I can load openplotter with motessier hat and my gps and ais are working

Thomas Staff replied 5 months ago

Hmm, nevertheless this is quite strange. I will check if I have the same issue if hdmi_safe is commented. Thanks for the input!

Regards,
Thomas

Christophe Brouillet answered 5 months ago

Hello Thomas and Rob.
Rob, do you mean you modified your config.txt file, by changing “#hdmi_safe=1” to “hdmi_safe=1” ?
Regards,
Christophe

Rob Comerford replied 5 months ago

Yes that is correct, I did that to get it to work but then I changed it to the following
# uncomment if you get no picture on HDMI for a default “safe” mode
# hdmi_safe=1
hdmi_force_hotplug=1
hdmi_ignore_edid=0xa5000080
config_hdmi_boost=4
hdmi_group=2
hdmi_mode=4
disable_overscan=0
overscan_left=30
overscan_right=30
overscan_top=15
overscan_bottom=15

Christophe Brouillet replied 5 months ago

Thanks for your answer Rob.
I tried with hdmi_safe=1 (with no #) but unfortunatly it’s not working better.
I guess I’ll have to further investigate.
Cheers,
Christophe

Rob Comerford replied 5 months ago

Did you try this, leave the hash tag on hdmi_safe=1 and add the lines below it.

# hdmi_safe=1
hdmi_force_hotplug=1
hdmi_ignore_edid=0xa5000080
config_hdmi_boost=4
hdmi_group=2
hdmi_mode=4
disable_overscan=0
overscan_left=30
overscan_right=30
overscan_top=15
overscan_bottom=15

Rob Comerford replied 5 months ago

Did you try this, leave the hash tag on hdmi_safe=1 and add the lines below it.

# hdmi_safe=1
hdmi_force_hotplug=1
hdmi_ignore_edid=0xa5000080
config_hdmi_boost=4
hdmi_group=2
hdmi_mode=4
disable_overscan=0
overscan_left=30
overscan_right=30
overscan_top=15
overscan_bottom=15

Christophe Brouillet replied 4 months ago

Hi Rob,
I tried both and only the display changes. The GPS/AIS are still not working.
I’ll try to get some support from Rooco.
Cheers,
Christophe

Christophe Brouillet replied 4 months ago

I tried today with an external antenna and it works like a charm.
I’ll see at sea how it works with and without the external antenna.

Thomas Staff replied 4 months ago

Hello Christophe,
do you still have issues with GPS and/or AIS? Does GPS work with internal patch antenna as well?

Regards,
Thomas

 

To comment on questions or provide answers, please login first.
Register | Login